蒹葭苍苍,白露为霜。
所谓伊人,在水一方。

Selenium使用chromedriver与Chrome版本对照表

在使用selenium启动谷歌Chrome浏览器的时候,是需要用到chromedirver的,两者之间的版本是需要匹配的,否则会出现下面类似的报错:

  1: Exception in thread "main" org.openqa.selenium.WebDriverException: unknown error: call function result missing 'value'
  2:  
  3:   (Session info: chrome=65.0.3325.31)
  4:   (Driver info: chromedriver=2.33.506120 (e3e53437346286c0bc2d2dc9aa4915ba81d9023f),platform=Windows NT 6.1.7601 SP1 x86) 
  5: (WARNING: The server did not provide any stacktrace information)
  6: Command duration or timeout: 0 milliseconds

这个例子中就是因为谷歌浏览器用的是65的版本,chromedriver用的是2.33的版本,而对于谷歌65的版本来说,与它匹配的chromedriver的版本是2.37或2.38,不匹配时就会出现上面的错误,使用匹配的版本后该问题即可解决。

下面是谷歌浏览器与chromedriver的版本对应关系,供参考:

ChromeDriver v2.43 (2018-10-16)———-Supports Chrome v69-71

ChromeDriver v2.42 (2018-09-13)———-Supports Chrome v68-70

ChromeDriver v2.41 (2018-07-27)———-Supports Chrome v67-69

ChromeDriver v2.40 (2018-06-07)———-Supports Chrome v66-68

ChromeDriver v2.39 (2018-05-30)———-Supports Chrome v66-68

ChromeDriver v2.38 (2018-04-17)———-Supports Chrome v65-67

ChromeDriver v2.37 (2018-03-16)———-Supports Chrome v64-66

ChromeDriver v2.36 (2018-03-02)———-Supports Chrome v63-65

ChromeDriver v2.35 (2018-01-10)———-Supports Chrome v62-64

chromedriver 镜像 – ChromeDriver Mirror
赞(0) 打赏
未经允许不得转载:酷居科技 » Selenium使用chromedriver与Chrome版本对照表
分享到: 更多 (0)

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

酷居科技 更专业 更高效

联系我们插件开发

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏